XGRIDSドキュメント
  • 简体中文
  • English
  • 繁體中文
  • 日本語
  • Deutsch
  • Español
  • Italiano
  • Français
  • Русский
  • 简体中文
  • English
  • 繁體中文
  • 日本語
  • Deutsch
  • Español
  • Italiano
  • Français
  • Русский
  • PortalCam

    • 製品概要
    • デバイスの基本操作
    • LCC Scan App の使用
    • メンテナンスとお手入れ
    • FAQ
  • Lixel K シリーズ

    • Lixel K1

      • 製品概要
      • デバイスの基本操作
      • デバイスのアクティベーションと接続
      • デバイス収集
      • 絶対座標のポイントクラウドデータを取得する
      • マップフュージョン
      • 典型的なシーンにおける経路計画の推奨
      • 注意事項
      • FAQ
    • Lixel K2

      • 製品概要
      • デバイスの基本操作
      • デバイスのアクティベーションと接続
      • デバイス収集
      • 絶対座標のポイントクラウドデータを取得
      • マップフュージョン
      • 典型的なシーンにおける経路計画の推奨
      • 注意事項
      • FAQ
  • Lixel L シリーズ

    • Lixel L2 Pro

      • 製品概要
      • デバイスの基本操作
      • デバイスのアクティベーションと接続
      • デバイス収集
      • 絶対座標のポイントクラウドデータを取得する
      • 実時計測機能
      • 付録
      • FAQ
  • Lixel Studio

    • バージョンと著作権
    • インストールとアクティベーション
    • ソフトウェアインターフェース
    • ファイル操作
    • プロジェクト処理
    • ツール
    • 2D 作図
    • 業界応用
    • 設定
    • デバイス接続
  • Lixel CyberColor

    • LCC Studio

      • はじめに
      • バージョンと更新
      • ダウンロードとインストール
      • インターフェース概要とナビゲーション
      • 再構築前の準備
      • モデル再構築
      • 単一モデル再構築
      • 地図合成
      • 空地融合
      • 航空撮影再構築
      • マイモデル
      • その他の機能
      • 設定とアカウント
      • Converter
      • 動画再構築
      • よくある質問 / FAQ
    • LCC Scene Editor

      • バージョンと更新
      • アカウントとサインイン
      • 製品概要とホーム画面
      • エディター画面
      • ナビゲーションモード
      • ファイル
      • 設定
      • 編集
      • ウィンドウ
      • グローバルツールバー
      • アセットとプロパティ
      • 左ツールバー
      • ビューポイント
      • ポータル
      • スカイボックス
      • アノテーション
      • 測定
      • フライスルー
      • シーンレポート
      • 3D レイアウト
      • ミニマップ
      • プレビューモード(Viewer)
      • ヘルプ
      • よくある質問(FAQ)
      • スポーンポイント
    • LCC Model Editor

      • バージョンと更新
      • ユーザーガイド
      • 概要とインターフェース
      • ファイル操作
      • セレクター
      • モデルの編集
      • 測定
      • カラーグレーディング
      • アセット管理
      • 設定とヘルプ
      • よくある質問
    • Capture Guide

      • 概要
      • 撮影デバイス概要
      • 一般的な撮影の原則
      • 屋内シーンの撮影
      • 屋外シーンの撮影
      • 大規模撮影(マップフュージョン)
      • 空地マップフュージョン撮影
      • オブジェクト撮影
      • 人物撮影
      • ビデオ再構築撮影
      • HD Enhancement
      • 制御点(Lixel P1)
      • FAQ とトラブルシューティング
    • バージョン履歴
  • プラグインと SDK

    • Unreal

      • 概要
      • クイックスタート - Windows
      • クイックスタート - Linux
      • クイックスタート - Quest3
      • エディションとライセンス
      • レンダリング
      • 画面調節
      • 法線とライティング
      • シーン編集
      • パフォーマンスパラメーター
      • パフォーマンス最適化ガイド
      • サードパーティおよびエンジンプラグインとの連携
      • プロキシメッシュ
      • 読み込みアニメーション
      • コリジョン
      • ナビゲーションシステム対応
      • Single layer water 対応
      • ローカライズ
      • よくある質問
      • トラブルシューティング
      • ログと診断
      • お問い合わせ
      • API リファレンス

        • ALCCActorBase
        • ULCCComponentBase
        • ULCCComponent
        • ULCC2Component
        • SOG / SPZ / PLY Actors
        • ALCC2ProxyMesh
        • ALCCClippingVolume
        • ALCCSectionPlane
        • ULCCUtilLibrary
        • Enums
        • Structs
      • 更新履歴

        • v3.3.1
        • v3.0.0
        • v2.2.1
        • v1.0.0
        • v0.9.0
        • v0.8.0
        • v0.7.1
        • v0.6.1
        • v0.5.2
        • v0.4.1
        • v0.4.0
        • v0.3.0
        • v0.0.5
        • v0.0.4
        • v0.0.3
        • v0.0.2
        • v0.0.1

Linux で 3DGS シーンをレンダリングする

このドキュメントでは、Unreal Engine のインストールから始めて、LCC4Unreal のインストール、C++ プロジェクトの作成、LCC データの読み込み、コンパイル、実行、Linux アプリケーションのパッケージ化までを解説します。

1. 推奨ハードウェア・ソフトウェア環境

項目推奨
オペレーティングシステムUbuntu 22.04
CPUIntel/AMD クアッドコア 2.5 GHz 以上。ソースビルドではコア数が多いほうを推奨
メモリ32 GB。ソースビルドでは 64 GB 以上を推奨
グラフィックスカードNVIDIA GeForce RTX 2080 以上の性能を持つ単体グラフィックスカード
ビデオメモリ8 GB 以上
IDEVS Code または Rider
ディスク300 GB 以上

2. Unreal Engine のインストール方法を選ぶ

Linux では 2 通りの Unreal Engine インストール方法があります。

方法特徴適した用途
ビルド済みバージョン(Installed Build)ダウンロードして完全に展開すればすぐ使える。C++ プロジェクトの作成もより簡単初めての場合はこちらを推奨
ソースビルドエンジンのソースを変更できる。初回ビルドに長時間かかるエンジンやプラグイン内部を変更する必要がある開発者

LCC4Unreal を使うだけで Unreal Engine のソースを変更する必要がない場合は、ビルド済みバージョンを選んでください。

注: LCC4Unreal はビルド済みの形で提供され、公式エンジンバイナリに対応しています。エンジンのソースを変更しないでください。変更したエンジンはプラグインと互換性がなくなり、読み込み失敗や動作異常の原因になります。


2.1 方法 A: Unreal Engine Linux ビルド済みバージョンをインストールする(推奨)

  1. Epic 公式の Unreal Engine for Linux ページを開く

  2. Epic Games アカウントでサインインする

  3. 必要な Unreal Engine バージョンの .zip アーカイブをダウンロードする

    Epic Games のページから Unreal Engine Linux ビルド済みバージョンをダウンロードする

    Epic Games 公式ページから必要な Unreal Engine Linux ビルド済みパッケージを選んでダウンロードする

  4. ファイルマネージャーでエンジン用のディレクトリを作成する。例:

    /home/[USER]/Unreal/Engines/UnrealEngine
    
  5. アーカイブ内のすべてのファイルとディレクトリを、そのエンジンルートディレクトリに展開する。UnrealEditor という単一ファイルだけをコピーしないこと。そうするとエンジンの実行とビルドに必要な他の内容が欠けます。

  6. ファイルマネージャーでエンジンルートディレクトリに入り、空白部分を右クリックして Open in Terminal を選択する。以降のコマンドは正しいエンジンディレクトリで実行する必要があります。

    Unreal Engine のルートディレクトリで Linux のターミナルを開く

    完全に展開した Unreal Engine のルートディレクトリに入り、そこからターミナルを開く

  7. Unreal Engine エディターを起動する

一般形:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

実行権限がないと表示される場合:

chmod +x "/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
例:
chmod +x "/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

2.1.1 C++ 開発用のツールチェーンを準備する

Epic Games の Linux 開発クイックスタート に従い、Unreal Engine のディレクトリで次を実行します。

cd "/[UE_ROOT]/Engine/Build/BatchFiles/Linux"
./SetupToolchain.sh
例:
cd "/home/alice/Unreal/Engines/UnrealEngine/Engine/Build/BatchFiles/Linux"
./SetupToolchain.sh

2.2 方法 B: Unreal Engine をソースからビルドする

Unreal Engine のソースビルドが既に動作している場合は、セクション 4 に進んでください。

2.2.1 ソースを取得する

GitHub から取得します: https://github.com/EpicGames/UnrealEngine

Epic Games の GitHub リポジトリから Unreal Engine のソースを取得する

Epic Games の Unreal Engine GitHub リポジトリにアクセスし、必要なバージョンのソースを取得する

2.2.2 依存関係とネイティブツールチェーンをダウンロードする

cd "/[UE_ROOT]"
./Setup.sh
例:
cd "/home/alice/Unreal/Engines/UnrealEngine"
./Setup.sh
Setup.sh を実行して Unreal Engine のソース依存関係と Linux ツールチェーンをダウンロードする

Setup.sh でソースビルドに必要な依存関係と Linux ネイティブツールチェーンをダウンロードする

成功の判定基準:

  • コマンドが最後に正常終了する
  • fatal メッセージがなく、未処理のダウンロード失敗もない
  • Engine/Extras/ThirdPartyNotUE/SDKs/HostLinux に対応する Unreal Engine のツールチェーンが存在する

次のように表示される場合:

fatal: not a git repository

ソースの取得元、現在のディレクトリ、または Git のメタデータに問題があります。無視してコンパイルを続けないでください。まず現在のターミナルが正しい Unreal Engine のルートディレクトリにあるか確認します。

2.2.3 プロジェクトファイルを生成する

cd "/[UE_ROOT]"
./GenerateProjectFiles.sh
例:
cd "/home/alice/Unreal/Engines/UnrealEngine"
./GenerateProjectFiles.sh
GenerateProjectFiles.sh を実行して Unreal Engine のプロジェクトファイルと Makefile を生成する

Unreal Engine のソース用にプロジェクトファイルと Linux の Makefile を生成する

2.2.4 UnrealEditor をコンパイルする

初回ビルドではメモリ不足を避けるため、並列ジョブ数を制限します。既定では make -j4 UnrealEditor で問題ありません。メモリが 32 GB のみの場合は make -j2 UnrealEditor を使います。エンジンの Makefile に個別のターゲットがない場合は make -j4 を使います。

cd "/[UE_ROOT]"
make -j4 UnrealEditor

# Use this with only 32 GB of memory:
make -j2 UnrealEditor

# Use this when the Makefile provides no separate target:
make -j4
make で UnrealEditor のソースターゲットをコンパイルする

並列ジョブ数を制限して UnrealEditor のソースビルドをコンパイルする

初回のソースビルドで数百から数千のアクションが実行されるのは正常です。これらは空のプロジェクトのソースファイルではなく、エンジン自体に属するものです。ビルド時間は CPU、メモリ、ディスクによって変わります。

成功したかどうかを確認します。

test -x "/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" \
  && echo "Source build UnrealEditor is ready" \
  || echo "Build not finished"
例:
test -x "/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" \
  && echo "Source build UnrealEditor is ready" \
  || echo "Build not finished"

プロジェクトブラウザーを起動します。

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"
UnrealEditor のソースビルドを起動して Unreal のプロジェクトブラウザーを開く

UnrealEditor のソースビルドがコンパイルされた後に Unreal のプロジェクトブラウザーを起動する


3. VS Code をインストールして設定する

3.1 VS Code と C++ 開発ツールをインストールする

Ubuntu では公式の Visual Studio Code サイトからダウンロードしてインストールするか、ディストリビューションが対応するパッケージ方式を使います。

VS Code で C++ プロジェクトをコンパイルする前に、セクション 2 の Unreal Engine Linux ツールチェーンのインストールを完了し、C++ の基本的なコンパイル・デバッグツールを準備します。Ubuntu のバージョンとチームの環境に応じて build-essential、clang、lldb、cmake などの一般的なツールをインストールしてください。実際のコンパイラーバージョンは、使用する Unreal Engine バージョンの要件と SetupToolchain.sh/Setup.sh がインストールしたツールチェーンに従います。

次の VS Code 拡張機能を推奨します。

  • C/C++: コードの参照、補完、デバッグ
  • C/C++ Extension Pack: C++ 開発向けの一般的な追加機能
  • CodeLLDB: Linux での LLDB デバッグ
  • Makefile Tools: Makefile のターゲットの確認と実行(任意)

Epic Games の公式ドキュメントも参考にできます: Setting up VS Code for Unreal Engine

3.2 VS Code のワークスペースを生成して開く

C++ プロジェクトを作成すると、通常はプロジェクトディレクトリに .vscode/ と <ProjectName>.code-workspace が含まれます。存在しない場合は次を実行します。

"/[UE_ROOT]/GenerateProjectFiles.sh" \
  -vscode \
  -project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -game \
  -engine

VS Code で File → Open Workspace from File... を選択し、<ProjectName>.code-workspace を開きます。単一の .cpp ファイルだけを開かないでください。

VS Code で Unreal Engine プロジェクトの code-workspace を開く

生成された .code-workspace を開いて Unreal Engine C++ プロジェクトの設定を読み込む

4. C++ プロジェクトを作成する

4.1 Unreal Engine を起動する

ターミナルから実行します。

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

4.2 プロジェクトブラウザーの設定

Unreal のプロジェクトブラウザーで次のように設定します。

  1. Games を選択する

  2. Blank を選択する

  3. Project Defaults を C++ に設定する

  4. Target Platform を Desktop に設定する

  5. Quality Preset は、最初のテストでは Scalable、高性能ワークステーションでは Maximum を選択する

  6. Starter Content は必要に応じて選択する

  7. プロジェクトの保存先を入力する

    /home/[USER]/Unreal/Projects
    
  8. プロジェクト名を入力する

    [PROJECT_NAME]
    
  9. Create をクリックする

Unreal のプロジェクトブラウザーで Games と Blank の C++ テンプレートを選択する

Games カテゴリーで Blank テンプレートを選択し、プロジェクトタイプを C++ に設定する

Unreal Engine C++ プロジェクトの保存先とプロジェクト名を設定する

プロジェクトの保存先、名前、プラットフォームのオプションを設定して C++ プロジェクトを作成する

プロジェクト名とパスには、次のものだけを使用します。

  • 半角英字
  • 数字
  • アンダースコア

漢字、スペース、&、括弧などの特殊文字は使用しないでください。

4.3 ビルド済みバージョンとソースビルドでは挙動が異なる

ケース A: ビルド済みバージョン(Installed Build)

通常の流れは次のとおりです。

create project → auto-compile <ProjectName>Editor → open VS Code → open the new project editor

古いプロジェクトブラウザーのウィンドウが一時的に閉じます。これは Unreal Engine が新しい .uproject を読み込むエディタープロセスを起動するためです。

ケース B: ソースビルド

通常の流れは次のとおりです。

create project → generate Source/, Makefile, .vscode/ → close project browser → open VS Code

Unreal Engine のソースビルドでは、新しいプロジェクトを自動でビルドして開かない場合があり、開発者が IDE またはターミナルで先にコンパイルすることを想定しています。これは VS Code の設定ミスではなく、プロジェクトの作成が失敗したことも意味しません。

この時点でプロジェクトには通常、次のものだけが含まれます。

.vscode/
Config/
Content/
Intermediate/
Saved/
Source/
Makefile
[PROJECT_NAME].code-workspace
[PROJECT_NAME].uproject

まだ存在しないもの:

Binaries/Linux/

これはプロジェクトのモジュールがまだコンパイルされていないことを意味します。

5. プラグインなしで初回コンパイルする

LCC4Unreal をインストールしない状態で空のプロジェクトを一度コンパイルし、Unreal Engine、ツールチェーン、プロジェクト自体が動作することを確認します。

5.1 VS Code でコンパイルする(推奨)

  1. セクション 3.2 の手順で <ProjectName>.code-workspace を生成して開く
  2. VS Code のサイドバーで Run and Debug を開く
  3. 上部の構成リストで <ProjectName>Editor (Development) を選択する
  4. 起動ボタンをクリックして初回コンパイルを実行する
  5. ビルドの完了を待ち、C++ のコンパイルエラーがないことを確認する。初回ビルドに時間がかかるのは正常です。
VS Code の Run and Debug でプロジェクトの Editor Development 構成をコンパイルする

<ProjectName>Editor (Development) 構成を選択してプロジェクトの初回 C++ コンパイルを完了する

ビルドが成功すると、VS Code から直接プロジェクトのエディターを起動できます。

5.2 任意: プロジェクトの Makefile を使う

cd "/[UE_PROJECTS_DIR]/[PROJECT_NAME]"
make "[PROJECT_NAME]Editor"
例:
cd "/home/alice/Unreal/Projects/Test2"
make "Test2Editor"
Linux のターミナルでプロジェクトの Makefile を使って Editor ターゲットをコンパイルする

プロジェクトの Makefile を通じて <ProjectName>Editor ターゲットをコンパイルする

5.3 コンパイル成功後にプロジェクトを開く

グラフィカルな方法: ファイルマネージャーで <ProjectName>.uproject を見つけ、右クリックして Open With Unreal Engine Editor を選択します。この方法は、対象の Unreal Engine バージョンがシステムに正しく関連付けられている場合に使えます。

Linux のファイルマネージャーで uproject を右クリックして Unreal Engine Editor で開く

プロジェクトの .uproject ファイルを右クリックして Unreal Engine Editor で開くことを選択する

コマンドラインの方法: UnrealEditor と .uproject の両方のフルパスを指定します。複数の Unreal Engine バージョンが共存する場合、こちらのほうが確実にプロジェクトを開けます。

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject"
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" "/home/alice/Unreal/Projects/Test2/Test2.uproject"

エディターでプロジェクトが開いたら、エディターを閉じてプラグインのインストールに進みます。

指定した C++ プロジェクトを開いている Unreal Engine

指定した Unreal Engine バージョンでプロジェクトを読み込む

Unreal Engine エディターのメイン画面で C++ プロジェクトが正常に開いた状態

空の C++ プロジェクトがコンパイルに成功し、Unreal Engine エディターで開かれる

6. LCC4Unreal をインストールする

Linux 版のプラグインは現在開発者プラットフォームからダウンロードできません。メールでの申請が必要です。sdk@xgrids.com に以下のテンプレートでお申し込みください:

  • 会社名:
  • 用途:プラグインの使用目的
  • エンジンバージョン:必要な Unreal Engine バージョン
  • 認知経路:プラグインをどこで知ったか

6.1 関連するプログラムを閉じる

プラグインをコピーする前に、次を行います。

  1. プロジェクトを保存する
  2. Unreal Engine エディターを閉じる
  3. UnrealEditor のバックグラウンドプロセスが終了するのを待つ
  4. VS Code は開いたままでもよいが、同時にプロジェクトをビルドしないこと

UnrealEditor がまだ動作しているかどうかを確認します。

pgrep -a UnrealEditor

出力がなければエディターは終了しています。

6.2 プラグイン全体をプロジェクトにコピーする

  1. プロジェクトのルートに Plugins ディレクトリを作成する

    mkdir -p "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Plugins"
    
    例:
    mkdir -p "/home/alice/Unreal/Projects/Test2/Plugins"
    
  2. ダウンロードしたプラグインパッケージを展開し、LCC4Unreal フォルダー全体をプロジェクトにコピーする。最終的なディレクトリは次のようになる必要があります。

    [PROJECT_ROOT]/Plugins/LCC4Unreal/
    

    Binaries、Content、個別のファイルだけをコピーしないでください。また Plugins/LCC4Unreal/LCC4Unreal/ のように入れ子が重複したディレクトリを作らないでください。

  3. プラグインの記述ファイルが存在することを確認する。ディレクトリには次が含まれる必要があります。

    [PROJECT_ROOT]/Plugins/LCC4Unreal/LCC4Unreal.uplugin
    

    リリースパッケージによって実際の .uplugin のファイル名が変わる場合は、それが 1 階層深い場所ではなく Plugins/LCC4Unreal/ の直下にあることを確認します。

LCC4Unreal プラグインフォルダー全体をプロジェクトの Plugins ディレクトリにコピーする

LCC4Unreal フォルダー全体を [PROJECT_ROOT]/Plugins/LCC4Unreal にコピーし、.uplugin ファイルを確認する

6.3 プロジェクトを再起動する

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject"
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" "/home/alice/Unreal/Projects/Test2/Test2.uproject"

このコマンドは、どの Unreal Engine を使うかと、どのプロジェクトを開くかの両方を指定します。複数の Unreal Engine バージョンが共存する場合、.uproject をダブルクリックするよりも確実で、あるバージョンをグローバルな既定として登録する必要もありません。

6.4 リビルドの確認が表示された場合の対応

確認メッセージは次のようになります。

The following modules are missing or built with a different engine version.
Would you like to rebuild them now?

これは、プロジェクトの動的ライブラリが存在しないか、現在の Unreal Engine バージョンと一致していないことを意味します。

  • コマンド内の Unreal Engine ルートのフルパスが正しいと確認できている場合は Yes/Rebuild を選択する
  • すぐに完了してエディターが正常に開く場合は、プロジェクトモジュールの増分ビルドが行われています
  • 毎回このメッセージが表示される場合は、毎回異なるエンジンを使っていないか、Binaries/Linux に書き込み権限があるか、システム時刻が正しいかを確認する
  • 複数エンジンの環境では、いったんメッセージを閉じてから、セクション 13 の Build.sh コマンドで明示的にビルドする

7. データ形式に合った Actor を選ぶ

データ形式ごとに対応する Actor が必要です。

データ形式Unreal Engine で検索する ActorC++ クラス名
.lcc2LCC2ActorALCC2Actor
.lccLCC ActorALCCActor
.sogSogActorASogActor
.spzSpzActorASpzActor
.plyPlyActorAPlyActor

以下の手順では .lcc2 データと LCC2Actor を例にします。他の形式では、表にある対応する Actor を使ってください。

7.1 LCC2Actor を追加してデータを読み込む

  1. LCC4Unreal のパネルで LCC2Actor をクリックして追加する

    LCC4Unreal のパネルからシーンに LCC2Actor を追加する

    .lcc2 データ形式に合わせて LCC4Unreal のパネルで LCC2Actor を追加する

  2. World Outliner で LCC2Actor を選択する

  3. Details パネルで Actions を見つける

  4. Load をクリックする

  5. .lcc2 のデータファイルを選択する

    LCC2Actor の Actions パネルで lcc2 データを選択して読み込む

    LCC2Actor の Details パネルから .lcc2 のデータファイルを読み込む

  6. データの読み込みが完了するのを待つ

    lcc2 データの読み込みに成功し Unreal Engine のシーンに表示された状態

    読み込みが完了すると .lcc2 データが Unreal Engine のビューポートに表示される

大きなデータを読み込んでいる間、エディターが一時的に応答しなくなることがあります。すぐに強制終了せず、メモリ、ビデオメモリ、Output Log を確認してください。

8. 非アセットの LCC データをパッケージ化に含める

.lcc2、.lcc、.sog、.spz、.ply は通常、Unreal Engine の .uasset ファイルではありません。ファイルを Content に置くだけではインストールパッケージに含まれません。

推奨ディレクトリ:

/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Content/LCCData/

次を開きます。

Edit → Project Settings → Packaging

次の項目を見つけます。

Additional Non-Asset Directories To Copy

次を追加します。

LCCData

Packaging には 2 種類の非アセットディレクトリ設定があります。

設定データの形態用途
Additional Non-Asset Directories To Copy通常のファイルとしてパッケージ出力にコピーされる出力ディレクトリ内でデータを見える状態にして差し替えたい場合
Additional Non-Asset Directories To Packagepak ファイルに格納されるデータを個別ファイルとして露出させず pak 内に含めたい場合

注:Additional Non-Asset Directories To Package でデータを pak に格納すると、コリジョンデータが正常にロードできない。これは現行バージョンの既知の不具合で、次のリリースで修正予定である。コリジョン機能が必要な場合は Additional Non-Asset Directories To Copy を使用する。

入力するのは Content 直下のトップレベルディレクトリ名(例: LCCData)であり、ファイルパスではない。Content/ プレフィックスは不要。

Packaging の Additional Non-Asset Directories To Copy に LCCData を追加する

Content/LCCData をパッケージ化時にコピーされる非アセットディレクトリとして設定する

その後、LCC Actor または LCC2Actor が読み込む相対パスが、パッケージ化後のディレクトリと一致していることを確認します。

8.1 起動マップを設定する

次を開きます。

Edit → Project Settings → Maps & Modes

Default Maps で Game Default Map を、LCC Actor/LCC2Actor と設定済みのデータパスを含む対象レベルに設定します。その後レベルとプロジェクト設定を保存し、パッケージ化したアプリケーションが空のマップで起動しないようにします。

Maps and Modes で Unreal Engine プロジェクトの Game Default Map を設定する

Maps & Modes の Default Maps で、パッケージ化したアプリケーションの起動時に使う Game Default Map を設定する

9. パッケージ化前のチェックリスト

パッケージ化の前に各項目を確認します。

  • [ ] 正しい Unreal Engine バージョンを使用している
  • [ ] LCC4Unreal プラグインのパッケージが Unreal Engine バージョンと Linux のアーキテクチャに一致している
  • [ ] <ProjectName>Editor Linux Development のコンパイルが成功する
  • [ ] プラグインが有効になっている
  • [ ] Pro ライセンスが有効である(Pro 版の機能を使う場合のみ必要。エディションとライセンス を参照)
  • [ ] エディターの Play で LCC データが表示される
  • [ ] Game Default Map が設定されている
  • [ ] パッケージ化するデータが Additional Non-Asset Directories To Copy に追加されている
  • [ ] ディスクの空き容量が十分ある
  • [ ] 出力ディレクトリに書き込み権限がある
  • [ ] すべてのレベルとアセットが保存されている
  • [ ] まず Development のパッケージを作成し、成功してから Shipping を試す

10. Project Launcher で Linux 向けにパッケージ化する

10.1 Project Launcher を開く

Unreal Engine エディターで次を選択します。

Platforms → Project Launcher
Unreal Engine の Platforms メニューから Project Launcher を開く

Platforms メニューから Project Launcher を開く

次をクリックします。

Add → Create Custom Profile
Project Launcher でカスタムの起動プロファイルを作成する

Add → Create Custom Profile から Linux 向けのパッケージ化プロファイルを作成する

10.2 プロファイルを設定する

  1. カスタムプロファイルで、ターゲットプラットフォームに Linux を選択し、コンテンツのパッケージ化方式を Pak ファイルに設定する

  2. ビルド結果のアーカイブを有効にし、書き込み可能なアーカイブディレクトリを選択する。パッケージ化後に配布可能なバージョンが実際に保存されるのはそのディレクトリです。

    Project Launcher のカスタムプロファイルで Linux と Pak を選択しアーカイブディレクトリを設定する

    ターゲットプラットフォームを Linux に設定し、Pak ファイルを選択してアーカイブを有効にし、パッケージ化の出力ディレクトリを指定する

  3. カスタムプロファイルの右側にある起動アイコンをクリックする

パッケージ化には通常、次の処理が含まれます。

Build → Cook → Stage → Package → Archive

初回のパッケージ化は増分よりも時間がかかります。一時的に同じパーセンテージで止まっているだけで強制停止しないでください。成功すると次のような出力が表示されます。

BUILD SUCCESSFUL

10.3 「Querying」のままになる場合

次の項目を順に確認します。

  1. Unreal Engine がプラットフォームと SDK の検出を終えるのを待つ
  2. Window → Developer Tools → Output Log を開く
  3. Turnkey、SDK、Linux、Error を検索する
  4. 現在のホストが Linux で、ターゲットプラットフォームも Linux であることを確認する
  5. Unreal Engine のソースビルドの依存関係とツールチェーンが Setup.sh でインストールされていることを確認する
  6. ビルド済みバージョンでは SetupToolchain.sh を実行済みであることを確認する
  7. 重複して開いている Project Launcher のウィンドウを閉じ、開き直す
  8. 別のターミナルで同じプロジェクトを同時にビルドしない

11. コマンドラインでパッケージ化する(任意)

グラフィカルなパッケージ化が安定したら、RunUAT を使えます。

mkdir -p "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Packaged"

"/[UE_ROOT]/Engine/Build/BatchFiles/RunUAT.sh" BuildCookRun \
  -project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -noP4 \
  -targetplatform=Linux \
  -clientconfig=Development \
  -build \
  -cook \
  -stage \
  -pak \
  -archive \
  -archivedirectory="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Packaged"
例:
mkdir -p "/home/alice/Unreal/Projects/Test2/Packaged"

"/home/alice/Unreal/Engines/UnrealEngine/Engine/Build/BatchFiles/RunUAT.sh" BuildCookRun \
  -project="/home/alice/Unreal/Projects/Test2/Test2.uproject" \
  -noP4 \
  -targetplatform=Linux \
  -clientconfig=Development \
  -build \
  -cook \
  -stage \
  -pak \
  -archive \
  -archivedirectory="/home/alice/Unreal/Projects/Test2/Packaged"

-archive と -archivedirectory を使う場合、最終的に実行できるバージョンは Saved/StagedBuilds/Linux にあると思い込まず、指定したアーカイブディレクトリを確認してください。

プロジェクトが特定のマップを使用する場合は、プロジェクト設定と使用中の Unreal Engine のコマンドパラメーターに従ってマップの指定を追加します。初めての場合はまず Project Launcher を使い、コマンドパラメーターの不足によるパッケージの不完全さを避けてください。

12. パッケージ化した結果を実行する

12.1 アーカイブした結果を実行する

Project Launcher でアーカイブを有効にした場合、または RunUAT で -archive -archivedirectory="..." を使った場合は、実際に設定したアーカイブディレクトリに移動します。Unreal Engine のバージョンによってはそこに Linux サブディレクトリが追加で作成されることがあるため、まずプロジェクトの起動スクリプトを探してから実行します。

cd "/[ARCHIVE_DIR]"
find . -maxdepth 3 -type f -name "*.sh" -print

chmod +x "./[SUBDIR]/[PROJECT_NAME].sh"
"./[SUBDIR]/[PROJECT_NAME].sh"
例(アーカイブ結果が Packaged/Linux にある場合):
cd "/home/alice/Unreal/Projects/Test2/Packaged"
find . -maxdepth 3 -type f -name "*.sh" -print
chmod +x "./Linux/Test2.sh"
"./Linux/Test2.sh"
Linux のファイルマネージャーでアーカイブしたパッケージ化結果を確認して起動する

Project Launcher または RunUAT で設定したアーカイブディレクトリに入り、プロジェクトのスクリプトを起動する

12.2 アーカイブしていない Stage 出力を実行する

アーカイブを行わず、Stage の結果を直接確認する必要がある場合にのみ、次のディレクトリから実行します。

cd "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Saved/StagedBuilds/Linux"
chmod +x "./[PROJECT_NAME].sh"
"./[PROJECT_NAME].sh"
例:
cd "/home/alice/Unreal/Projects/Test2/Saved/StagedBuilds/Linux"
chmod +x "./Test2.sh"
"./Test2.sh"

実行後に確認する項目:

  • 起動する
  • 既定のマップが正しい
  • LCC データが表示される
  • アプリケーションを閉じた後に残留プロセスがない
パッケージ化した Linux アプリケーションを実行し LCC シーンが読み込まれた状態

パッケージ化した Linux アプリケーションを起動し、既定のマップ、LCC データ、ライセンス機能を確認する

13. コマンドリファレンス

以下のコマンド内の [UE_ROOT]、[UE_PROJECTS_DIR]、[PROJECT_NAME]、[ARCHIVE_DIR] はプレースホルダーです。実行前に実際のフルパスと名前に置き換えてください。

プロジェクトブラウザーを起動する:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor"
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor"

VS Code のプロジェクトファイルを生成する:

"/[UE_ROOT]/GenerateProjectFiles.sh" \
  -vscode \
  -project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -game \
  -engine
例:
"/home/alice/Unreal/Engines/UnrealEngine/GenerateProjectFiles.sh" \
  -vscode \
  -project="/home/alice/Unreal/Projects/Test2/Test2.uproject" \
  -game \
  -engine

プロジェクトの Editor ターゲットをコンパイルする:

"/[UE_ROOT]/Engine/Build/BatchFiles/Linux/Build.sh" \
  "[PROJECT_NAME]Editor" Linux Development \
  -Project="/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject" \
  -WaitMutex
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Build/BatchFiles/Linux/Build.sh" \
  "Test2Editor" Linux Development \
  -Project="/home/alice/Unreal/Projects/Test2/Test2.uproject" \
  -WaitMutex

特定の Unreal Engine で特定のプロジェクトを開く:

"/[UE_ROOT]/Engine/Binaries/Linux/UnrealEditor" "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/[PROJECT_NAME].uproject"
例:
"/home/alice/Unreal/Engines/UnrealEngine/Engine/Binaries/Linux/UnrealEditor" "/home/alice/Unreal/Projects/Test2/Test2.uproject"

アーカイブした結果を実行する:

cd "/[ARCHIVE_DIR]"
find . -maxdepth 3 -type f -name "*.sh" -print
chmod +x "./[SUBDIR]/[PROJECT_NAME].sh"
"./[SUBDIR]/[PROJECT_NAME].sh"

アーカイブしていない Stage 出力を実行する:

cd "/[UE_PROJECTS_DIR]/[PROJECT_NAME]/Saved/StagedBuilds/Linux"
chmod +x "./[PROJECT_NAME].sh"
"./[PROJECT_NAME].sh"
例(アーカイブしていない Stage 出力):
cd "/home/alice/Unreal/Projects/Test2/Saved/StagedBuilds/Linux"
chmod +x "./Test2.sh"
"./Test2.sh"
前へ
クイックスタート - Windows
次へ
クイックスタート - Quest3